What’s Vulnerable › Vulnerabilities
CVE-2022-2004: AutomationDirect DirectLOGIC with Ethernet Communication Uncontrolled Resource Consumption
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-31 · updated 2026-06-17
- Weakness: CWE-400
Description
AutomationDirect DirectLOGIC is vulnerable to a a specially crafted packet can be sent continuously to the PLC to prevent access from DirectSoft and other devices, causing a denial-of-service condition. This issue affects: AutomationDirect DirectLOGIC D0-06 series CPUs D0-06DD1 versions prior to 2.72; D0-06DD2 versions prior to 2.72; D0-06DR versions prior to 2.72; D0-06DA versions prior to 2.72; D0-06AR versions prior to 2.72; D0-06AA versions prior to 2.72; D0-06DD1-D versions prior to 2.72; D0-06DD2-D versions prior to 2.72; D0-06DR-D versions prior to 2.72;
Affected products
- AutomationDirect D0-06Aa Firmware: before 2.72 — fixed in 2.72
- AutomationDirect D0-06Ar Firmware: before 2.72 — fixed in 2.72
- AutomationDirect D0-06Da Firmware: before 2.72 — fixed in 2.72
- AutomationDirect D0-06Dd1-D Firmware: before 2.72 — fixed in 2.72
- AutomationDirect D0-06Dd1 Firmware: before 2.72 — fixed in 2.72
- AutomationDirect D0-06Dd2-D Firmware: before 2.72 — fixed in 2.72
- AutomationDirect D0-06Dd2 Firmware: before 2.72 — fixed in 2.72
- AutomationDirect D0-06Dr-D Firmware: before 2.72 — fixed in 2.72
- AutomationDirect D0-06Dr Firmware: before 2.72 — fixed in 2.72
How to fix
Upgrade to a fixed version: AutomationDirect D0-06Aa Firmware 2.72; AutomationDirect D0-06Ar Firmware 2.72; AutomationDirect D0-06Da Firmware 2.72; AutomationDirect D0-06Dd1-D Firmware 2.72; AutomationDirect D0-06Dd1 Firmware 2.72; AutomationDirect D0-06Dd2-D Firmware 2.72; AutomationDirect D0-06Dd2 Firmware 2.72; AutomationDirect D0-06Dr-D Firmware 2.72; AutomationDirect D0-06Dr Firmware 2.72. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-167-03
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-167-03
Get alerted when CVE-2022-2004 or the next vulnerability affects your stack