What’s Vulnerable › Vulnerabilities
CVE-2022-2015: Cross-site Scripting (XSS) - Stored in jgraph/drawio
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository jgraph/drawio prior to 19.0.2.
Affected products
- jgraph/drawio: before 19.0.2 — fixed in 19.0.2
How to fix
Upgrade to a fixed version: jgraph/drawio 19.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/jgraph/drawio/commit/3d3f819d7a04da7d53b37cc0ca4269c157ba2825
- https://huntr.dev/bounties/0d32f448-155c-4b71-9291-9e8bcd522b37
- https://github.com/jgraph/drawio/commit/3d3f819d7a04da7d53b37cc0ca4269c157ba2825
- https://huntr.dev/bounties/0d32f448-155c-4b71-9291-9e8bcd522b37
Get alerted when CVE-2022-2015 or the next vulnerability affects your stack