What’s Vulnerable › Vulnerabilities
CVE-2022-2022: Cross-site Scripting (XSS) - Stored in nocodb/nocodb
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository nocodb/nocodb prior to 0.91.7.
Affected products
- nocodb: before 0.91.7 — fixed in 0.91.7
How to fix
Upgrade to a fixed version: nocodb 0.91.7. Check the vendor advisory for mitigations.
References
- https://github.com/nocodb/nocodb/commit/ffad5a318ad60d1da1c75dd28152827b94c92e9d
- https://huntr.dev/bounties/f6082949-40d3-411c-b613-23ada2691913
- https://github.com/nocodb/nocodb/commit/ffad5a318ad60d1da1c75dd28152827b94c92e9d
- https://huntr.dev/bounties/f6082949-40d3-411c-b613-23ada2691913
Get alerted when CVE-2022-2022 or the next vulnerability affects your stack