What’s Vulnerable › Vulnerabilities
CVE-2022-2023: Incorrect Use of Privileged APIs in polonel/trudesk
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-20 · updated 2026-06-17
- Weakness: CWE-648
Description
Incorrect Use of Privileged APIs in GitHub repository polonel/trudesk prior to 1.2.4.
Affected products
- polonel/trudesk: before 1.2.4 — fixed in 1.2.4
How to fix
Upgrade to a fixed version: polonel/trudesk 1.2.4. Check the vendor advisory for mitigations.
References
- https://github.com/polonel/trudesk/commit/83fd5a89319ba2c2f5934722e39b08aba9b3a4ac
- https://huntr.dev/bounties/0f35b1d3-56e6-49e4-bc5a-830f52e094b3
- https://github.com/polonel/trudesk/commit/83fd5a89319ba2c2f5934722e39b08aba9b3a4ac
- https://huntr.dev/bounties/0f35b1d3-56e6-49e4-bc5a-830f52e094b3
Get alerted when CVE-2022-2023 or the next vulnerability affects your stack