What’s Vulnerable › Vulnerabilities
CVE-2022-2042: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-10 · updated 2026-10-08
- Weakness: CWE-416
Description
Use After Free in GitHub repository vim/vim prior to 8.2.
Affected products
- Apple macOS: before 11.7; from 12.0 before 12.6 — fixed in 11.7, 12.6
- vim/vim: before 8.2.5072 — fixed in 8.2.5072
How to fix
Upgrade to a fixed version: Apple macOS 11.7, 12.6; vim/vim 8.2.5072. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- http://seclists.org/fulldisclosure/2022/Oct/43
- http://seclists.org/fulldisclosure/2022/Oct/45
- https://github.com/vim/vim/commit/2813f38e021c6e6581c0c88fcf107e41788bc835
- https://huntr.dev/bounties/8628b4cd-4055-4059-aed4-64f7fdc10eba
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://support.apple.com/kb/HT213443
- https://support.apple.com/kb/HT213444
- https://support.apple.com/kb/HT213488
- http://seclists.org/fulldisclosure/2022/Oct/28
Get alerted when CVE-2022-2042 or the next vulnerability affects your stack