What’s Vulnerable › Vulnerabilities
CVE-2022-2050: WP Paginate < 2.1.9 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP-Paginate WordPress plugin before 2.1.9 does not escape one of its settings, which could allow high privilege users to perform Stored Cross-Site Scripting attacks when unfiltered_html is disallowed
Affected products
- WP-Paginate: before 2.1.9 — fixed in 2.1.9
How to fix
Upgrade to a fixed version: WP-Paginate 2.1.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/016453e3-803b-4a67-8ea7-2d228c2998d4
- https://wpscan.com/vulnerability/016453e3-803b-4a67-8ea7-2d228c2998d4
Get alerted when CVE-2022-2050 or the next vulnerability affects your stack