What’s Vulnerable › Vulnerabilities
CVE-2022-20673: Cisco Common Services Platform Collector Cross-Site Scripting Vulnerabilities
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple vulnerabilities in the web-based management interface of Cisco Common Services Platform Collector (CSPC) Software could allow an unauthenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the interface. These vulnerabilities are due to insufficient validation of user-supplied input by the web-based management interface. An attacker could exploit these vulnerabilities by persuading a user of the interface to click a crafted link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the interface or access sensitive, browser-based information.
Affected products
- Cisco Common Services Platform Collector Software: before 2.10.0.2 — fixed in 2.10.0.2
How to fix
Upgrade to a fixed version: Cisco Common Services Platform Collector Software 2.10.0.2. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cspc-multi-xss-tyDFjhwb
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cspc-multi-xss-tyDFjhwb
Get alerted when CVE-2022-20673 or the next vulnerability affects your stack