What’s Vulnerable › Vulnerabilities
CVE-2022-20698: Clam AntiVirus (ClamAV) Denial of Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-14 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the OOXML parsing module in Clam AntiVirus (ClamAV) Software version 0.104.1 and LTS version 0.103.4 and prior versions could allow an unauthenticated, remote attacker to cause a denial of service condition on an affected device. The vulnerability is due to improper checks that may result in an invalid pointer read. An attacker could exploit this vulnerability by sending a crafted OOXML file to an affected device. An exploit could allow the attacker to cause the ClamAV scanning process to crash, resulting in a denial of service condition.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 20.04, 20.10, 21.04
- Cisco ClamAV: before 0.103.5; from 0.104.0 before 0.104.2 — fixed in 0.103.5, 0.104.2
- Debian Linux: 9.0, 10.0, 11.0
How to fix
Upgrade to a fixed version: Cisco ClamAV 0.103.5, 0.104.2. Check the vendor advisory for mitigations.
References
- https://blog.clamav.net/2022/01/clamav-01035-and-01042-security-patch.html
- https://security.gentoo.org/glsa/202310-01
- https://blog.clamav.net/2022/01/clamav-01035-and-01042-security-patch.html
- https://security.gentoo.org/glsa/202310-01
Get alerted when CVE-2022-20698 or the next vulnerability affects your stack