What’s Vulnerable › Vulnerabilities
CVE-2022-20715: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software Remote Access SSL VPN Denial of Service Vulnerability
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-03 · updated 2026-08-11
- Weakness: CWE-399
Description
A vulnerability in the remote access SSL VPN features of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition on an affected device. This vulnerability is due to improper validation of errors that are logged as a result of client connections that are made using remote access VPN. An attacker could exploit this vulnerability by sending crafted requests to an affected system. A successful exploit could allow the attacker to cause the affected device to restart, resulting in a DoS condition.
Affected products
- Cisco ASA Software: before 9.8.4.44; from 9.9 before 9.12.4.38; from 9.13 before 9.14.4; from 9.15 before 9.15.1.21; from 9.16.0 before 9.16.2.14; from 9.17.0 before 9.17.1.7 — fixed in 9.12.4.38, 9.14.4, 9.15.1.21, 9.16.2.14, 9.17.1.7, 9.8.4.44
- Cisco Firepower Threat Defense Software: before 6.4.0.15; from 6.5.0 before 6.6.5.2; from 6.7.0 before 7.0.2; 7.1.0 — fixed in 6.4.0.15, 6.6.5.2, 7.0.2
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.12.4.38, 9.14.4, 9.15.1.21, 9.16.2.14; Cisco Firepower Threat Defense Software 6.4.0.15, 6.6.5.2, 7.0.2. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asa-dos-tL4uA4AA
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asa-dos-tL4uA4AA
Get alerted when CVE-2022-20715 or the next vulnerability affects your stack