What’s Vulnerable › Vulnerabilities
CVE-2022-2074
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-19 · updated 2026-06-17
Description
In affected versions of Octopus Deploy it is possible to perform a Regex Denial of Service using the Variable Project Template.
Affected products
- Octopus Deploy Octopus Server: from 0.9 through 0.9.620.4; from 1.0 through 1.6.3.1723; from 2.0 through 2.6.5; from 3.0.0 through 3.17.14; from 4.0.4 through 4.1.10; from 2018.1.0 through 2018.12.1 — fixed in 2022.1.2894, 2022.2.6872, 2022.3.4953
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.1.2894, 2022.2.6872, 2022.3.4953. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2022/sa2022-11/
- https://advisories.octopus.com/post/2022/sa2022-11/
Get alerted when CVE-2022-2074 or the next vulnerability affects your stack