What’s Vulnerable › Vulnerabilities
CVE-2022-20742: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software IPsec IKEv2 VPN Information Disclosure Vulnerability
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-03 · updated 2026-08-11
- Weakness: CWE-325
Description
A vulnerability in an IPsec VPN library of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to read or modify data within an IPsec IKEv2 VPN tunnel. This vulnerability is due to an improper implementation of Galois/Counter Mode (GCM) ciphers. An attacker in a man-in-the-middle position could exploit this vulnerability by intercepting a sufficient number of encrypted messages across an affected IPsec IKEv2 VPN tunnel and then using cryptanalytic techniques to break the encryption. A successful exploit could allow the attacker to decrypt, read, modify, and re-encrypt data that is transmitted across an affected IPsec IKEv2 VPN tunnel.
Affected products
- Cisco ASA Software: before 9.12.4.38; from 9.13.0 before 9.14.4; from 9.15.0 before 9.15.1.21; from 9.16.0 before 9.16.2.14; from 9.17.0 before 9.17.1.7 — fixed in 9.12.4.38, 9.14.4, 9.15.1.21, 9.16.2.14, 9.17.1.7
- Cisco Firepower Threat Defense Software: before 6.4.0.15; from 6.5.0 before 6.6.5.2; from 7.0.0 before 7.0.2; 7.1.0 — fixed in 6.4.0.15, 6.6.5.2, 7.0.2
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.12.4.38, 9.14.4, 9.15.1.21, 9.16.2.14; Cisco Firepower Threat Defense Software 6.4.0.15, 6.6.5.2, 7.0.2. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asaftd-ipsec-mitm-CKnLr4
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asaftd-ipsec-mitm-CKnLr4
Get alerted when CVE-2022-20742 or the next vulnerability affects your stack