What’s Vulnerable › Vulnerabilities
CVE-2022-20757: Cisco Firepower Threat Defense Software Denial of Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-03 · updated 2026-08-11
- Weakness: CWE-770
Description
A vulnerability in the connection handling function in Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition on an affected device. This vulnerability is due to improper traffic handling when platform limits are reached. An attacker could exploit this vulnerability by sending a high rate of UDP traffic through an affected device. A successful exploit could allow the attacker to cause all new, incoming connections to be dropped, resulting in a DoS condition.
Affected products
- Cisco Firepower Threat Defense Software: before 6.4.0.15; from 6.5.0 before 6.6.5.2; from 6.7.0 before 7.0.2; 7.1.0 — fixed in 6.4.0.15, 6.6.5.2, 7.0.2
How to fix
Upgrade to a fixed version: Cisco Firepower Threat Defense Software 6.4.0.15, 6.6.5.2, 7.0.2. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ftd-dos-JnnJm4wB
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ftd-dos-JnnJm4wB
Get alerted when CVE-2022-20757 or the next vulnerability affects your stack