What’s Vulnerable › Vulnerabilities
CVE-2022-20759: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software Web Services Interface Privilege Escalation Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 28.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-03 · updated 2026-08-11
- Weakness: CWE-266
Description
A vulnerability in the web services interface for remote access VPN features of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an authenticated, but unprivileged, remote attacker to elevate privileges to level 15. This vulnerability is due to improper separation of authentication and authorization scopes. An attacker could exploit this vulnerability by sending crafted HTTPS messages to the web services interface of an affected device. A successful exploit could allow the attacker to gain privilege level 15 access to the web management interface of the device. This includes privilege level 15 access to the device using management tools like the Cisco Adaptive Security Device Manager (ASDM) or the Cisco Security Manager (CSM). Note: With Cisco FTD Software, the impact is lower than the CVSS score suggests because the affected web management interface allows for read access only.
Affected products
- Cisco ASA Software: before 9.12.4.38; from 9.13.0 before 9.14.4; from 9.15.0 before 9.15.1.21; from 9.16.0 before 9.16.2.14; from 9.17.0 before 9.17.1.7 — fixed in 9.12.4.38, 9.14.4, 9.15.1.21, 9.16.2.14, 9.17.1.7
- Cisco Firepower Threat Defense Software: before 6.4.0.15; from 6.5.0 before 6.6.5.2; from 6.7.0 before 7.0.2; 7.1.0 — fixed in 6.4.0.15, 6.6.5.2, 7.0.2
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.12.4.38, 9.14.4, 9.15.1.21, 9.16.2.14; Cisco Firepower Threat Defense Software 6.4.0.15, 6.6.5.2, 7.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/orangecertcc/security-research/security/advisories/GHSA-gq88-gqmj-7v24
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asaftd-mgmt-privesc-BMFMUvye
- https://github.com/orangecertcc/security-research/security/advisories/GHSA-gq88-gqmj-7v24
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asaftd-mgmt-privesc-BMFMUvye
Get alerted when CVE-2022-20759 or the next vulnerability affects your stack