What’s Vulnerable › Vulnerabilities
CVE-2022-2078
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-30 · updated 2026-10-14
- Weakness: CWE-121
Description
A vulnerability was found in the Linux kernel's nft_set_desc_concat_parse() function .This flaw allows an attacker to trigger a buffer overflow via nft_set_desc_concat_parse() , causing a denial of service and possibly to run code.
Affected products
- Debian Linux: 11.0
- Linux kernel: before 5.19 — fixed in 5.19
- Red Hat Enterprise Linux: 8.0, 9.0
- RedHat Virtualization: 4.0
How to fix
Upgrade to a fixed version: Linux kernel 5.19. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2096178
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/net/netfilter/nf_tables_api.c?id=fecf31ee395b0295f2d7260aa29946b7605f7c85
- https://www.debian.org/security/2022/dsa-5161
- https://bugzilla.redhat.com/show_bug.cgi?id=2096178
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/net/netfilter/nf_tables_api.c?id=fecf31ee395b0295f2d7260aa29946b7605f7c85
- https://www.debian.org/security/2022/dsa-5161
- https://cert-portal.siemens.com/productcert/html/ssa-794697.html
Get alerted when CVE-2022-2078 or the next vulnerability affects your stack