What’s Vulnerable › Vulnerabilities
CVE-2022-20788: Cisco Unified Communications Products Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-21 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the web-based management interface of Cisco Unified Communications Manager (Unified CM), Cisco Unified CM Session Management Edition (Unified CM SME), and Cisco Unity Connection could allow an unauthenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the interface. This vulnerability exists because the web-based management interface does not properly validate user-supplied input. An attacker could exploit this vulnerability by persuading a user of the interface to click a crafted link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive browser-based information.
Affected products
- Cisco Unified Communications Manager: from 11.5\(1\) before 11.5\(1\)su11; from 12.5\(1\) before 12.5\(1\)su6; from 14.0 before 14su1 — fixed in 11.5\(1\)su11, 12.5\(1\)su6, 14su1
- Cisco Unity Connection: from 12.5\(1\) before 12.5\(1\)su6; from 14.0 before 14su1 — fixed in 12.5\(1\)su6, 14su1
How to fix
Upgrade to a fixed version: Cisco Unified Communications Manager 11.5\(1\)su11, 12.5\(1\)su6, 14su1; Cisco Unity Connection 12.5\(1\)su6, 14su1. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cucm-xss-6MCe4kPF
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cucm-xss-6MCe4kPF
Get alerted when CVE-2022-20788 or the next vulnerability affects your stack