What’s Vulnerable › Vulnerabilities
CVE-2022-2079: Cross-site Scripting (XSS) - Stored in nocodb/nocodb
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository nocodb/nocodb prior to 0.91.7+.
Affected products
- nocodb: before 0.91.7 — fixed in 0.91.7
How to fix
Upgrade to a fixed version: nocodb 0.91.7. Check the vendor advisory for mitigations.
References
- https://github.com/nocodb/nocodb/commit/362f8f0869989bc13bdcd66c6fc9c86ac79b9992
- https://huntr.dev/bounties/2615adf2-ff40-4623-97fb-2e4a3800202a
- https://github.com/nocodb/nocodb/commit/362f8f0869989bc13bdcd66c6fc9c86ac79b9992
- https://huntr.dev/bounties/2615adf2-ff40-4623-97fb-2e4a3800202a
Get alerted when CVE-2022-2079 or the next vulnerability affects your stack