What’s Vulnerable › Vulnerabilities
CVE-2022-20801: Cisco Small Business RV Series Routers Command Injection Vulnerabilities
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-04 · updated 2026-06-17
- Weakness: CWE-77
Description
Multiple vulnerabilities in the web-based management interface of Cisco Small Business RV340 and RV345 Routers could allow an authenticated, remote attacker to inject and execute arbitrary commands on the underlying operating system of an affected device. These vulnerabilities are due to insufficient validation of user-supplied input. An attacker could exploit these vulnerabilities by sending malicious input to an affected device. A successful exploit could allow the attacker to execute arbitrary commands on the underlying Linux operating system of the affected device. To exploit these vulnerabilities, an attacker would need to have valid Administrator credentials on the affected device.
Affected products
- Cisco Rv340 Firmware: before 1.0.03.27 — fixed in 1.0.03.27
- Cisco Rv340W Firmware: before 1.0.03.27 — fixed in 1.0.03.27
- Cisco Rv345 Firmware: before 1.0.03.27 — fixed in 1.0.03.27
- Cisco Rv345P Firmware: before 1.0.03.27 — fixed in 1.0.03.27
How to fix
Upgrade to a fixed version: Cisco Rv340 Firmware 1.0.03.27; Cisco Rv340W Firmware 1.0.03.27; Cisco Rv345 Firmware 1.0.03.27; Cisco Rv345P Firmware 1.0.03.27. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-smb-rv-cmd-inj-8Pv9JMJD
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-smb-rv-cmd-inj-8Pv9JMJD
Get alerted when CVE-2022-20801 or the next vulnerability affects your stack