What’s Vulnerable › Vulnerabilities
CVE-2022-20802: Cisco Enterprise Chat and Email Stored Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-27 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the web interface of Cisco Enterprise Chat and Email (ECE) could allow an authenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the interface. This vulnerability is due to insufficient validation of user-supplied input that is processed by the web interface. An attacker could exploit this vulnerability by sending a crafted HTTP request to the affected system. A successful exploit could allow the attacker to execute arbitrary code in the context of the interface or access sensitive, browser-based information. To successfully exploit this vulnerability, an attacker would need valid agent credentials.
Affected products
- Cisco Enterprise Chat and Email: before 12.6\(1\)es2 — fixed in 12.6\(1\)es2
How to fix
Upgrade to a fixed version: Cisco Enterprise Chat and Email 12.6\(1\)es2. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ece-strd-xss-BqFXO9D2
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ece-strd-xss-BqFXO9D2
Get alerted when CVE-2022-20802 or the next vulnerability affects your stack