What’s Vulnerable › Vulnerabilities
CVE-2022-20812: Cisco Expressway Series and Cisco TelePresence Video Communication Server Vulnerabilities
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-06 · updated 2026-06-17
- Weakness: CWE-158
Description
Multiple vulnerabilities in the API and in the web-based management interface of Cisco Expressway Series and Cisco TelePresence Video Communication Server (VCS) could allow a remote attacker to overwrite arbitrary files or conduct null byte poisoning attacks on an affected device. Note: Cisco Expressway Series refers to the Expressway Control (Expressway-C) device and the Expressway Edge (Expressway-E) device. For more information about these vulnerabilities, see the Details section of this advisory.
Affected products
- Cisco Expressway: before x14.0.7 — fixed in x14.0.7
- Cisco TelePresence Video Communication Server (VCS) Expressway: before x14.0.7 — fixed in x14.0.7
How to fix
Upgrade to a fixed version: Cisco Expressway x14.0.7; Cisco TelePresence Video Communication Server (VCS) Expressway x14.0.7. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-expressway-csrf-sqpsSfY6
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-expressway-overwrite-3buqW8LH
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-expressway-csrf-sqpsSfY6
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-expressway-overwrite-3buqW8LH
Get alerted when CVE-2022-20812 or the next vulnerability affects your stack