What’s Vulnerable › Vulnerabilities
CVE-2022-20857: Cisco Nexus Dashboard Unauthorized Access Vulnerabilities
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-21 · updated 2026-06-17
- Weakness: CWE-306
Description
Multiple vulnerabilities in Cisco Nexus Dashboard could allow an unauthenticated, remote attacker to execute arbitrary commands, read or upload container image files, or perform a cross-site request forgery attack. For more information about these vulnerabilities, see the Details section of this advisory.
Affected products
- Cisco Nexus Dashboard: from 1.0 before 2.2\(1e\) — fixed in 2.2\(1e\)
How to fix
Upgrade to a fixed version: Cisco Nexus Dashboard 2.2\(1e\). Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ndb-mhcvuln-vpsBPJ9y
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ndb-mhcvuln-vpsBPJ9y
Get alerted when CVE-2022-20857 or the next vulnerability affects your stack