What’s Vulnerable › Vulnerabilities
CVE-2022-20869: Cisco BroadWorks Application Delivery Platform Software Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-10 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the web-based management interface of Cisco BroadWorks Application Delivery Platform Software could allow an unauthenticated, remote attacker to conduct a cross-site scripting attack against a user of the interface. This vulnerability exists because the web-based management interface does not properly validate user-supplied input. An attacker could exploit this vulnerability by persuading a user of the interface to click a crafted link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive browser-based information.
Affected products
- Cisco Broadworks: from 22.0 before 22.0.2022.06; from 23.0 before 23.0.2022.06; from 24.0 before 24.0.2022.06 — fixed in 22.0.2022.06, 23.0.2022.06, 24.0.2022.06
How to fix
Upgrade to a fixed version: Cisco Broadworks 22.0.2022.06, 23.0.2022.06, 24.0.2022.06. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-broadworks-xss-xbhfr4cD
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-broadworks-xss-xbhfr4cD
Get alerted when CVE-2022-20869 or the next vulnerability affects your stack