What’s Vulnerable › Vulnerabilities
CVE-2022-2089: Bold Page Builder < 4.3.3 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The Bold Page Builder WordPress plugin before 4.3.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed.
Affected products
- boldthemes Bold Page Builder: before 4.3.3 — fixed in 4.3.3
How to fix
Upgrade to a fixed version: boldthemes Bold Page Builder 4.3.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9fe7e9d5-7bdf-4ade-9a3c-b4af863fa4e8
- https://wpscan.com/vulnerability/9fe7e9d5-7bdf-4ade-9a3c-b4af863fa4e8
Get alerted when CVE-2022-2089 or the next vulnerability affects your stack