What’s Vulnerable › Vulnerabilities
CVE-2022-2090: Woo Discount Rules < 2.4.2 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Discount Rules for WooCommerce WordPress plugin before 2.4.2 does not escape a parameter before outputting it back in an attribute of the plugin's discount rule page, leading to Reflected Cross-Site Scripting
Affected products
- flycart Discount Rules for WooCommerce: before 2.4.2 — fixed in 2.4.2
How to fix
Upgrade to a fixed version: flycart Discount Rules for WooCommerce 2.4.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0201f365-7acb-4640-bd3f-7119432f4917
- https://wpscan.com/vulnerability/0201f365-7acb-4640-bd3f-7119432f4917
Get alerted when CVE-2022-2090 or the next vulnerability affects your stack