What’s Vulnerable › Vulnerabilities
CVE-2022-20909: Cisco Nexus Dashboard Privilege Escalation Vulnerabilities
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-22 · updated 2026-06-17
- Weakness: CWE-367
Description
Multiple vulnerabilities in Cisco Nexus Dashboard could allow an authenticated, local attacker to elevate privileges on an affected device. These vulnerabilities are due to insufficient input validation during CLI command execution on an affected device. An attacker could exploit these vulnerabilities by authenticating as the rescue-user and executing vulnerable CLI commands using a malicious payload. A successful exploit could allow the attacker to elevate privileges to root on an affected device.
Affected products
- Cisco Nexus Dashboard: from 2.0 before 2.2\(1e\) — fixed in 2.2\(1e\)
How to fix
Upgrade to a fixed version: Cisco Nexus Dashboard 2.2\(1e\). Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ndb-mprvesc-EMhDgXe5
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ndb-mprvesc-EMhDgXe5
Get alerted when CVE-2022-20909 or the next vulnerability affects your stack