What’s Vulnerable › Vulnerabilities
CVE-2022-20914: Cisco Identity Services Engine Sensitive Information Disclosure Vulnerability
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-10 · updated 2026-06-17
- Weakness: CWE-549
Description
A vulnerability in the External RESTful Services (ERS) API of Cisco Identity Services Engine (ISE) Software could allow an authenticated, remote attacker to obtain sensitive information. This vulnerability is due to excessive verbosity in a specific REST API output. An attacker could exploit this vulnerability by sending a crafted HTTP request to the affected device. A successful exploit could allow the attacker to obtain sensitive information, including administrative credentials for an external authentication server. Note: To successfully exploit this vulnerability, the attacker must have valid ERS administrative credentials.
Affected products
- Cisco Identity Services Engine: from 2.4.0 before 2.6.0; 2.6.0, 2.6.0-patch1, 2.6.0-patch10, 2.6.0-patch2, 2.6.0-patch3, 2.6.0-patch5 (+20) — fixed in 2.6.0
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 2.6.0. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ise-pwd-WH64AhQF
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ise-pwd-WH64AhQF
Get alerted when CVE-2022-20914 or the next vulnerability affects your stack