What’s Vulnerable › Vulnerabilities
CVE-2022-20929
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-10 · updated 2026-06-17
- Weakness: CWE-347
Description
A vulnerability in the upgrade signature verification of Cisco Enterprise NFV Infrastructure Software (NFVIS) could allow an unauthenticated, local attacker to provide an unauthentic upgrade file for upload. This vulnerability is due to insufficient cryptographic signature verification of upgrade files. An attacker could exploit this vulnerability by providing an administrator with an unauthentic upgrade file. A successful exploit could allow the attacker to fully compromise the Cisco NFVIS system.
Affected products
- Cisco Enterprise NFV Infrastructure Software: from 3.5.1 before 4.9.1 — fixed in 4.9.1
How to fix
Upgrade to a fixed version: Cisco Enterprise NFV Infrastructure Software 4.9.1. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-NFVIS-ISV-BQrvEv2h
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-NFVIS-ISV-BQrvEv2h
Get alerted when CVE-2022-20929 or the next vulnerability affects your stack