What’s Vulnerable › Vulnerabilities
CVE-2022-20930: Cisco SD-WAN Software Arbitrary File Corruption Vulnerability
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-30 · updated 2026-06-17
- Weakness: CWE-88
Description
A vulnerability in the CLI of Cisco SD-WAN Software could allow an authenticated, local attacker to overwrite and possibly corrupt files on an affected system. This vulnerability is due to insufficient input validation. An attacker could exploit this vulnerability by injecting arbitrary commands that are executed as the root user account. A successful exploit could allow the attacker to overwrite arbitrary system files, which could result in a denial of service (DoS) condition.
Affected products
- Cisco Catalyst SD-WAN Manager: 20.8, 20.9
- Cisco Sd-Wan: before 20.6.2; 20.8, 20.9 — fixed in 20.6.2
- Cisco Sd-Wan Vbond Orchestrator: before 20.6.2; 20.8, 20.9 — fixed in 20.6.2
- Cisco Sd-Wan Vmanage: before 20.6.2 — fixed in 20.6.2
- Cisco Sd-Wan Vsmart Controller: before 20.6.2; 20.8, 20.9 — fixed in 20.6.2
How to fix
Upgrade to a fixed version: Cisco Sd-Wan 20.6.2; Cisco Sd-Wan Vbond Orchestrator 20.6.2; Cisco Sd-Wan Vmanage 20.6.2; Cisco Sd-Wan Vsmart Controller 20.6.2. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-sdwan-privesc-cli-xkGwmqKu
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-sdwan-privesc-cli-xkGwmqKu
Get alerted when CVE-2022-20930 or the next vulnerability affects your stack