What’s Vulnerable › Vulnerabilities
CVE-2022-20959: Cisco Identity Services Engine Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-26 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the External RESTful Services (ERS) API of Cisco Identity Services Engine (ISE) Software could allow an authenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the interface of an affected device. This vulnerability is due to insufficient input validation. An attacker could exploit this vulnerability by persuading an authenticated administrator of the web-based management interface to click a malicious link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive, browser-based information.
Affected products
- Cisco Identity Services Engine: from 2.4 before 2.7.0; 2.7.0, 2.7.0-patch1, 2.7.0-patch2, 2.7.0-patch3, 2.7.0-patch4, 2.7.0-patch5 (+13) — fixed in 2.7.0
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 2.7.0. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ise-xss-twLnpy3M
- https://yoroi.company/en/research/cve-advisory-full-disclosure-cisco-ise-cross-site-scripting/
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ise-xss-twLnpy3M
- https://yoroi.company/en/research/cve-advisory-full-disclosure-cisco-ise-cross-site-scripting/
Get alerted when CVE-2022-20959 or the next vulnerability affects your stack