What’s Vulnerable › Vulnerabilities
CVE-2022-2099: WooCommerce < 6.6.0 - Admin+ Stored HTML Injection
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-17 · updated 2026-06-17
- Weakness: CWE-116
Description
The WooCommerce WordPress plugin before 6.6.0 is vulnerable to stored HTML injection due to lack of escaping and sanitizing in the payment gateway titles
Affected products
- Automattic WooCommerce: before 6.6.0 — fixed in 6.6.0
How to fix
Upgrade to a fixed version: Automattic WooCommerce 6.6.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0316e5f3-3302-40e3-8ff4-be3423a3be7b
- https://wpscan.com/vulnerability/0316e5f3-3302-40e3-8ff4-be3423a3be7b
Get alerted when CVE-2022-2099 or the next vulnerability affects your stack