What’s Vulnerable › Vulnerabilities
CVE-2022-2100: Page Generator Plugin < 1.6.5 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Page Generator WordPress plugin before 1.6.5 does not sanitise and escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Page Generator: before 1.6.5 — fixed in 1.6.5
How to fix
Upgrade to a fixed version: Page Generator 1.6.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/7d8b7871-baa5-4a54-a9e9-2c9d302cdd12
- https://wpscan.com/vulnerability/7d8b7871-baa5-4a54-a9e9-2c9d302cdd12
Get alerted when CVE-2022-2100 or the next vulnerability affects your stack