What’s Vulnerable › Vulnerabilities
CVE-2022-21129
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-31 · updated 2026-06-17
- Weakness: CWE-78
Description
Versions of the package nemo-appium before 0.0.9 are vulnerable to Command Injection due to improper input sanitization in the 'module.exports.setup' function. **Note:** In order to exploit this vulnerability appium-running 0.1.3 has to be installed as one of nemo-appium dependencies.
Affected products
- nemo-appium: before 0.0.9 — fixed in 0.0.9
How to fix
Upgrade to a fixed version: nemo-appium 0.0.9. Check the vendor advisory for mitigations.
References
- https://github.com/paypal/nemo-appium/blob/master/index.js%23L27
- https://github.com/paypal/nemo-appium/commit/aa271d36dd5c81baae3c43aa2616c84f0ee4195f
- https://security.snyk.io/vuln/SNYK-JS-NEMOAPPIUM-3183747
- https://github.com/paypal/nemo-appium/blob/master/index.js%23L27
- https://github.com/paypal/nemo-appium/commit/aa271d36dd5c81baae3c43aa2616c84f0ee4195f
- https://security.snyk.io/vuln/SNYK-JS-NEMOAPPIUM-3183747
Get alerted when CVE-2022-21129 or the next vulnerability affects your stack