What’s Vulnerable › Vulnerabilities
CVE-2022-2113: Cross-site Scripting (XSS) - Stored in inventree/inventree
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-17 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository inventree/inventree prior to 0.7.2.
Affected products
- InvenTree: before 0.7.2 — fixed in 0.7.2
How to fix
Upgrade to a fixed version: InvenTree 0.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/inventree/inventree/commit/26bf51c20a1c9b3130ac5dd2e17649bece5ff84f
- https://huntr.dev/bounties/4cae8442-c042-43c2-ad89-6f666eaf3d57
- https://github.com/inventree/inventree/commit/26bf51c20a1c9b3130ac5dd2e17649bece5ff84f
- https://huntr.dev/bounties/4cae8442-c042-43c2-ad89-6f666eaf3d57
Get alerted when CVE-2022-2113 or the next vulnerability affects your stack