What’s Vulnerable › Vulnerabilities
CVE-2022-21132
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-10 · updated 2026-06-17
- Weakness: CWE-22
Description
Directory traversal vulnerability in pfSense-pkg-WireGuard pfSense-pkg-WireGuard 0.1.5 versions prior to 0.1.5_4 and pfSense-pkg-WireGuard 0.1.6 versions prior to 0.1.6_1 allows a remote authenticated attacker to lead a pfSense user to view a file outside the public folder.
Affected products
- pfSense-pkg-WireGuard: from 0.1.5 before 0.1.5_4; 0.1.6 — fixed in 0.1.5_4
How to fix
Upgrade to a fixed version: pfSense-pkg-WireGuard 0.1.5_4. Check the vendor advisory for mitigations.
References
- https://github.com/pfsense/FreeBSD-ports/commits/devel/net/pfSense-pkg-WireGuard
- https://jvn.jp/en/jp/JVN85572374/index.html
- https://github.com/pfsense/FreeBSD-ports/commits/devel/net/pfSense-pkg-WireGuard
- https://jvn.jp/en/jp/JVN85572374/index.html
Get alerted when CVE-2022-21132 or the next vulnerability affects your stack