What’s Vulnerable › Vulnerabilities
CVE-2022-2114: Data Tables Generator by Supsystic < 1.10.20 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Data Tables Generator by Supsystic WordPress plugin before 1.10.20 does not sanitise and escape some of its Table settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Data Tables Generator by Supsystic: before 1.10.20 — fixed in 1.10.20
How to fix
Upgrade to a fixed version: Data Tables Generator by Supsystic 1.10.20. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/59911ba4-fa06-498a-9e7c-0c337cce691c
- https://wpscan.com/vulnerability/59911ba4-fa06-498a-9e7c-0c337cce691c
Get alerted when CVE-2022-2114 or the next vulnerability affects your stack