What’s Vulnerable › Vulnerabilities
CVE-2022-21144: Denial of Service (DoS)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-01 · updated 2026-06-17
- Weakness: CWE-20
Description
This affects all versions of package libxmljs. When invoking the libxmljs.parseXml function with a non-buffer argument the V8 code will attempt invoking the .toString method of the argument. If the argument's toString value is not a Function object V8 will crash.
Affected products
- libxmljs: before 0.19.8 — fixed in 0.19.8
How to fix
Upgrade to a fixed version: libxmljs 0.19.8. Check the vendor advisory for mitigations.
References
- https://github.com/libxmljs/libxmljs/commit/2501807bde9b38cfaed06d1e140487516d91379d
- https://github.com/libxmljs/libxmljs/pull/594
- https://snyk.io/vuln/SNYK-JS-LIBXMLJS-2348756
- https://github.com/libxmljs/libxmljs/commit/2501807bde9b38cfaed06d1e140487516d91379d
- https://github.com/libxmljs/libxmljs/pull/594
- https://snyk.io/vuln/SNYK-JS-LIBXMLJS-2348756
Get alerted when CVE-2022-21144 or the next vulnerability affects your stack