What’s Vulnerable › Vulnerabilities
CVE-2022-2115: Popup Anything < 2.1.7 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Popup Anything WordPress plugin before 2.1.7 does not sanitise and escape a parameter before outputting it back in a frontend page, leading to a Reflected Cross-Site Scripting
Affected products
- Popup Anything – A Marketing Popup and Lead Generation Conversions: before 2.1.7 — fixed in 2.1.7
How to fix
Upgrade to a fixed version: Popup Anything – A Marketing Popup and Lead Generation Conversions 2.1.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1f0ae535-c560-4510-ae9a-059e2435ad39
- https://wpscan.com/vulnerability/1f0ae535-c560-4510-ae9a-059e2435ad39
Get alerted when CVE-2022-2115 or the next vulnerability affects your stack