What’s Vulnerable › Vulnerabilities
CVE-2022-21158
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-10 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored cross-site scripting vulnerability in marktext versions prior to v0.17.0 due to improper handling of the link (with javascript: scheme) inside the document may allow an attacker to execute an arbitrary script on the PC of the user using marktext.
Affected products
- MarkText: before 0.17.0 — fixed in 0.17.0
How to fix
Upgrade to a fixed version: MarkText 0.17.0. Check the vendor advisory for mitigations.
References
- https://github.com/marktext/marktext/releases/tag/v0.17.0
- https://jvn.jp/en/jp/JVN89524240/index.html
- https://github.com/marktext/marktext/releases/tag/v0.17.0
- https://jvn.jp/en/jp/JVN89524240/index.html
Get alerted when CVE-2022-21158 or the next vulnerability affects your stack