What’s Vulnerable › Vulnerabilities
CVE-2022-2116: Elementor Contact Form DB < 1.8.0 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Contact Form DB WordPress plugin before 1.8.0 does not sanitise and escape some parameters before outputting them back in attributes, leading to Reflected Cross-Site Scripting
Affected products
- Contact Form DB – Elementor: before 1.8.0 — fixed in 1.8.0
How to fix
Upgrade to a fixed version: Contact Form DB – Elementor 1.8.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/01568da4-2ecf-4cf9-8030-31868ce0a87a
- https://wpscan.com/vulnerability/01568da4-2ecf-4cf9-8030-31868ce0a87a
Get alerted when CVE-2022-2116 or the next vulnerability affects your stack