What’s Vulnerable › Vulnerabilities
CVE-2022-21164: Denial of Service (DoS)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-16 · updated 2026-06-17
Description
The package node-lmdb before 0.9.7 are vulnerable to Denial of Service (DoS) when defining a non-invokable ToString value, which will cause a crash during type check.
Affected products
- node-lmdb: before 0.9.7 — fixed in 0.9.7
How to fix
Upgrade to a fixed version: node-lmdb 0.9.7. Check the vendor advisory for mitigations.
References
- https://github.com/Venemo/node-lmdb/commit/97760104c0fd311206b88aecd91fa1f59fe2b85a
- https://snyk.io/vuln/SNYK-JS-NODELMDB-2400723
- https://github.com/Venemo/node-lmdb/commit/97760104c0fd311206b88aecd91fa1f59fe2b85a
- https://snyk.io/vuln/SNYK-JS-NODELMDB-2400723
Get alerted when CVE-2022-21164 or the next vulnerability affects your stack