What’s Vulnerable › Vulnerabilities
CVE-2022-2118: 404s < 3.5.1 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The 404s WordPress plugin before 3.5.1 does not sanitise and escape its fields, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- 404s: before 3.5.1 — fixed in 3.5.1
How to fix
Upgrade to a fixed version: 404s 3.5.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9a19af60-d6e6-4fa3-82eb-3636599b814c
- https://wpscan.com/vulnerability/9a19af60-d6e6-4fa3-82eb-3636599b814c
Get alerted when CVE-2022-2118 or the next vulnerability affects your stack