What’s Vulnerable › Vulnerabilities
CVE-2022-21186: Arbitrary Command Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 26.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-05 · updated 2026-06-17
Description
The package @acrontum/filesystem-template before 0.0.2 are vulnerable to Arbitrary Command Injection due to the fetchRepo API missing sanitization of the href field of external input.
Affected products
- @acrontum/filesystem-template: before 0.0.2 — fixed in 0.0.2
How to fix
Upgrade to a fixed version: @acrontum/filesystem-template 0.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/acrontum/filesystem-template/pull/14/commits/baeb727b60991ad82d9e63ac660883793abc0acc
- https://security.snyk.io/vuln/SNYK-JS-ACRONTUMFILESYSTEMTEMPLATE-2419071
- https://github.com/acrontum/filesystem-template/pull/14/commits/baeb727b60991ad82d9e63ac660883793abc0acc
- https://security.snyk.io/vuln/SNYK-JS-ACRONTUMFILESYSTEMTEMPLATE-2419071
Get alerted when CVE-2022-21186 or the next vulnerability affects your stack