What’s Vulnerable › Vulnerabilities
CVE-2022-21187: Command Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-14 · updated 2026-06-17
- Weakness: CWE-88
Description
The package libvcs before 0.11.1 are vulnerable to Command Injection via argument injection. When calling the update_repo function (when using hg), the url parameter is passed to the hg clone command. By injecting some hg options it was possible to get arbitrary command execution.
Affected products
- libvcs: before 0.11.1 — fixed in 0.11.1
How to fix
Upgrade to a fixed version: libvcs 0.11.1. Check the vendor advisory for mitigations.
References
- https://github.com/vcs-python/libvcs/blob/v0.11.1/CHANGES%23libvcs-0111-2022-03-12
- https://github.com/vcs-python/libvcs/pull/306
- https://snyk.io/vuln/SNYK-PYTHON-LIBVCS-2421204
- https://github.com/vcs-python/libvcs/blob/v0.11.1/CHANGES%23libvcs-0111-2022-03-12
- https://github.com/vcs-python/libvcs/pull/306
- https://snyk.io/vuln/SNYK-PYTHON-LIBVCS-2421204
Get alerted when CVE-2022-21187 or the next vulnerability affects your stack