What’s Vulnerable › Vulnerabilities
CVE-2022-21191
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-13 · updated 2026-06-17
- Weakness: CWE-78
Description
Versions of the package global-modules-path before 3.0.0 are vulnerable to Command Injection due to missing input sanitization or other checks and sandboxes being employed to the getPath function.
Affected products
- global-modules-path: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: global-modules-path 3.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/lorenzomigliorero/npm-node-utils/blob/b55dd81c597db657c9751332bb2242403fd3e26b/index.js%23L186
- https://github.com/rosen-vladimirov/global-modules-path/commit/edbdaff077ea0cf295b1469923c06bbccad3c180
- https://github.com/rosen-vladimirov/global-modules-path/releases/tag/v3.0.0
- https://security.snyk.io/vuln/SNYK-JS-GLOBALMODULESPATH-3167973
- https://github.com/lorenzomigliorero/npm-node-utils/blob/b55dd81c597db657c9751332bb2242403fd3e26b/index.js%23L186
- https://github.com/rosen-vladimirov/global-modules-path/commit/edbdaff077ea0cf295b1469923c06bbccad3c180
- https://github.com/rosen-vladimirov/global-modules-path/releases/tag/v3.0.0
- https://security.snyk.io/vuln/SNYK-JS-GLOBALMODULESPATH-3167973
Get alerted when CVE-2022-21191 or the next vulnerability affects your stack