What’s Vulnerable › Vulnerabilities
CVE-2022-21222: Regular Expression Denial of Service (ReDoS)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-30 · updated 2026-06-17
- Weakness: CWE-1333
Description
The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.
Affected products
- css-what: before 2.1.3 — fixed in 2.1.3
- Npm Css-What: before 2.1.3 — fixed in 2.1.3
How to fix
Upgrade to a fixed version: css-what 2.1.3; Npm Css-What 2.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/fb55/css-what/blob/a38effd5a8f5506d75c7f8f13cbd8c76248a3860/index.js%23L12
- https://lists.debian.org/debian-lts-announce/2023/03/msg00001.html
- https://security.snyk.io/vuln/SNYK-JS-CSSWHAT-3035488
- https://github.com/fb55/css-what/blob/a38effd5a8f5506d75c7f8f13cbd8c76248a3860/index.js%23L12
- https://lists.debian.org/debian-lts-announce/2023/03/msg00001.html
- https://security.snyk.io/vuln/SNYK-JS-CSSWHAT-3035488
Get alerted when CVE-2022-21222 or the next vulnerability affects your stack