What’s Vulnerable › Vulnerabilities
CVE-2022-21223: Command Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-01 · updated 2026-06-17
- Weakness: CWE-88
Description
The package cocoapods-downloader before 1.6.2 are vulnerable to Command Injection via hg argument injection. When calling the download function (when using hg), the url (and/or revision, tag, branch) is passed to the hg clone command in a way that additional flags can be set. The additional flags can be used to perform a command injection.
Affected products
- cocoapods-downloader: before 1.6.2 — fixed in 1.6.2
How to fix
Upgrade to a fixed version: cocoapods-downloader 1.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/CocoaPods/cocoapods-downloader/pull/127
- https://snyk.io/vuln/SNYK-RUBY-COCOAPODSDOWNLOADER-2414280
- https://github.com/CocoaPods/cocoapods-downloader/pull/127
- https://snyk.io/vuln/SNYK-RUBY-COCOAPODSDOWNLOADER-2414280
Get alerted when CVE-2022-21223 or the next vulnerability affects your stack