What’s Vulnerable › Vulnerabilities
CVE-2022-21227: Denial of Service (DoS)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-01 · updated 2026-06-17
Description
The package sqlite3 before 5.0.3 are vulnerable to Denial of Service (DoS) which will invoke the toString function of the passed parameter. If passed an invalid Function object it will throw and crash the V8 engine.
Affected products
- Ghost Foundation node-sqlite3: before 5.0.3 — fixed in 5.0.3
How to fix
Upgrade to a fixed version: Ghost Foundation node-sqlite3 5.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/TryGhost/node-sqlite3/commit/593c9d498be2510d286349134537e3bf89401c4a
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-2805470
- https://snyk.io/vuln/SNYK-JS-SQLITE3-2388645
- https://github.com/TryGhost/node-sqlite3/commit/593c9d498be2510d286349134537e3bf89401c4a
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-2805470
- https://snyk.io/vuln/SNYK-JS-SQLITE3-2388645
Get alerted when CVE-2022-21227 or the next vulnerability affects your stack