What’s Vulnerable › Vulnerabilities
CVE-2022-21235: Command Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-01 · updated 2026-06-17
- Weakness: CWE-88
Description
The package github.com/masterminds/vcs before 1.13.3 are vulnerable to Command Injection via argument injection. When hg is executed, argument strings are passed to hg in a way that additional flags can be set. The additional flags can be used to perform a command injection.
Affected products
- github.com/Masterminds/vcs: before 1.1.13 — fixed in 1.1.13
How to fix
Upgrade to a fixed version: github.com/Masterminds/vcs 1.1.13. Check the vendor advisory for mitigations.
References
- https://github.com/Masterminds/vcs/pull/105
- https://snyk.io/vuln/SNYK-GOLANG-GITHUBCOMMASTERMINDSVCS-2437078
- https://github.com/Masterminds/vcs/pull/105
- https://snyk.io/vuln/SNYK-GOLANG-GITHUBCOMMASTERMINDSVCS-2437078
Get alerted when CVE-2022-21235 or the next vulnerability affects your stack