What’s Vulnerable › Vulnerabilities
CVE-2022-2124: Buffer Over-read in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-19 · updated 2026-10-08
- Weakness: CWE-126
Description
Buffer Over-read in GitHub repository vim/vim prior to 8.2.
Affected products
- Apple macOS: before 11.7; from 12.0 before 12.6 — fixed in 11.7, 12.6
- Debian Linux: 9.0
- Fedoraproject Fedora: 35, 36
- vim/vim: before 8.2.5120 — fixed in 8.2.5120
How to fix
Upgrade to a fixed version: Apple macOS 11.7, 12.6; vim/vim 8.2.5120. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/41
- http://seclists.org/fulldisclosure/2022/Oct/43
- http://seclists.org/fulldisclosure/2022/Oct/45
- https://github.com/vim/vim/commit/2f074f4685897ab7212e25931eeeb0212292829f
- https://huntr.dev/bounties/8e9e056d-f733-4540-98b6-414bf36e0b42
- https://lists.debian.org/debian-lts-announce/2022/06/msg00014.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GFD2A4YLBR7OIRHTL7CK6YNMEIQ264CN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U743FMJGFQ35GBPCQ6OWMVZEJPDFVEWM/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://support.apple.com/kb/HT213443
Get alerted when CVE-2022-2124 or the next vulnerability affects your stack