What’s Vulnerable › Vulnerabilities
CVE-2022-21241
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting vulnerability in CSV+ prior to 0.8.1 allows a remote unauthenticated attacker to inject an arbitrary script or an arbitrary OS command via a specially crafted CSV file that contains HTML a tag.
Affected products
- Plus one CSV+: before 0.8.1 — fixed in 0.8.1
How to fix
Upgrade to a fixed version: Plus one CSV+ 0.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/plusone-masaki/csv-plus/releases/tag/v0.8.1
- https://jvn.jp/en/jp/JVN67396225/index.html
- https://github.com/plusone-masaki/csv-plus/releases/tag/v0.8.1
- https://jvn.jp/en/jp/JVN67396225/index.html
Get alerted when CVE-2022-21241 or the next vulnerability affects your stack