What’s Vulnerable › Vulnerabilities
CVE-2022-2129: Out-of-bounds Write in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-19 · updated 2026-10-08
- Weakness: CWE-787
Description
Out-of-bounds Write in GitHub repository vim/vim prior to 8.2.
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 35, 36
- vim/vim: before 8.2.5126 — fixed in 8.2.5126
How to fix
Upgrade to a fixed version: vim/vim 8.2.5126. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/d6211a52ab9f53b82f884561ed43d2fe4d24ff7d
- https://huntr.dev/bounties/3aaf06e7-9ae1-454d-b8ca-8709c98e5352
- https://lists.debian.org/debian-lts-announce/2022/11/msg00032.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GFD2A4YLBR7OIRHTL7CK6YNMEIQ264CN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U743FMJGFQ35GBPCQ6OWMVZEJPDFVEWM/
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/d6211a52ab9f53b82f884561ed43d2fe4d24ff7d
- https://huntr.dev/bounties/3aaf06e7-9ae1-454d-b8ca-8709c98e5352
- https://lists.debian.org/debian-lts-announce/2022/11/msg00032.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00023.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GFD2A4YLBR7OIRHTL7CK6YNMEIQ264CN/
Get alerted when CVE-2022-2129 or the next vulnerability affects your stack